import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "runScript(?<match>\\((?:\\g<match>|[^()]++)*\\))";
final String string = "runScript(\"test\")\n\n"
+ " runScript( \"test2\" )\n\n"
+ "runScript(ros.find(\"p\")+ \"script/test3\")\n\n"
+ "if( true) then { runScript(ros.find(\"p\")+ \"script/test4\")}\n\n\n"
+ "if( runScript(ros.find(\"p\")+ \"script/test5\") ) then{\n\n"
+ " print.ln(\"happy\")\n"
+ "}\n\n"
+ "runScript(\n\n"
+ "ros.find(\"p\")+ \"script/test6\"\n\n\n"
+ ")\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}