$re = '/runScript(?<match>\((?:\g<match>|[^()]++)*\))/';
$str = 'runScript("test")
runScript( "test2" )
runScript(ros.find("p")+ "script/test3")
if( true) then { runScript(ros.find("p")+ "script/test4")}
if( runScript(ros.find("p")+ "script/test5") ) then{
print.ln("happy")
}
runScript(
ros.find("p")+ "script/test6"
)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);