using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"runScript(?<match>\((?:\g<match>|[^()]++)*\))";
string input = @"runScript(""test"")
runScript( ""test2"" )
runScript(ros.find(""p"")+ ""script/test3"")
if( true) then { runScript(ros.find(""p"")+ ""script/test4"")}
if( runScript(ros.find(""p"")+ ""script/test5"") ) then{
print.ln(""happy"")
}
runScript(
ros.find(""p"")+ ""script/test6""
)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}