import Foundation
let pattern = #"runScript(?<match>\((?:\g<match>|[^()]++)*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
runScript("test")
runScript( "test2" )
runScript(ros.find("p")+ "script/test3")
if( true) then { runScript(ros.find("p")+ "script/test4")}
if( runScript(ros.find("p")+ "script/test5") ) then{
print.ln("happy")
}
runScript(
ros.find("p")+ "script/test6"
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)