package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`runScript(?<match>\((?:\g<match>|[^()]++)*\))`)
var str = `runScript("test")
runScript( "test2" )
runScript(ros.find("p")+ "script/test3")
if( true) then { runScript(ros.find("p")+ "script/test4")}
if( runScript(ros.find("p")+ "script/test5") ) then{
print.ln("happy")
}
runScript(
ros.find("p")+ "script/test6"
)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}