#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)" & @CRLF & _
" (?<json>" & @CRLF & _
" \{ (?:" & @CRLF & _
" [^{}"']+" & @CRLF & _
" |(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>" & @CRLF & _
" |(?&json)" & @CRLF & _
" )* \}" & @CRLF & _
" )" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"theObject\s*=\s*(?&json)"
Local $sString = "blablabla" & @CRLF & _
"" & @CRLF & _
"theObject = {" & @CRLF & _
"key1 = value1," & @CRLF & _
"key2 = "test } test"," & @CRLF & _
"key3 = {" & @CRLF & _
" key4 = value4," & @CRLF & _
" key5 = value5" & @CRLF & _
"}" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"blablabla" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")