import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<json>\n"
+ " \\{ (?:\n"
+ " [^\\{\\}\"']+\n"
+ " |(?<quote>[\"'])(?:[^\\\\\"']+|\\\\.)*\\k<quote>\n"
+ " |(?&json)\n"
+ " )* \\}\n"
+ " )\n"
+ ")\n\n"
+ "theObject\\s*=\\s*(?&json)";
final String string = "blablabla\n\n"
+ "theObject = {\n"
+ "key1 = value1,\n"
+ "key2 = \"test } test\",\n"
+ "key3 = {\n"
+ " key4 = value4,\n"
+ " key5 = value5\n"
+ "}\n"
+ "}\n\n"
+ "blablabla\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}