package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?(DEFINE)
(?<json>
\{ (?:
[^{}"']+
|(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)`)
var str = `blablabla
theObject = {
key1 = value1,
key2 = "test } test",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}