// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(?(DEFINE)
(?<json>
\{ (?:
[^{}"']+
|(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)"#).unwrap();
let string = "blablabla
theObject = {
key1 = value1,
key2 = \"test } test\",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}