using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)
(?<json>
\{ (?:
[^{}""']+
|(?<quote>[""'])(?:[^\\""']+|\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)";
string input = @"blablabla
theObject = {
key1 = value1,
key2 = ""test } test"",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}