use strict;
my $str = 'blablabla
theObject = {
key1 = value1,
key2 = "test } test",
key3 = {
    key4 = value4,
    key5 = value5
}
}
blablabla
';
my $regex = qr/(?(DEFINE)
    (?<json>
        \{ (?:
            [^{}"']+
            |(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>
            |(?&json)
        )* \}
    )
)
theObject\s*=\s*(?&json)/xp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}