re = /(?(DEFINE)
(?<json>
\{ (?:
[^{}"']+
|(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)/x
str = 'blablabla
theObject = {
key1 = value1,
key2 = "test } test",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end