import Foundation
let pattern = #"""
(?(DEFINE)
(?<json>
\{ (?:
[^{}"']+
|(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
blablabla
theObject = {
key1 = value1,
key2 = "test } test",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)