$re = '/(?(DEFINE)
(?<json>
\{ (?:
[^{}"\']+
|(?<quote>["\'])(?:[^\\\\"\']+|\\\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)/x';
$str = 'blablabla
theObject = {
key1 = value1,
key2 = "test } test",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);