const regex = /(?(DEFINE)
(?<json>
\{ (?:
[^{}"']+
|(?<quote>["'])(?:[^\\"']+|\\.)*\k<quote>
|(?&json)
)* \}
)
)
theObject\s*=\s*(?&json)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?<json>
\\{ (?:
[^{}"\']+
|(?<quote>["\'])(?:[^\\\\"\']+|\\\\.)*\\k<quote>
|(?&json)
)* \\}
)
)
theObject\\s*=\\s*(?&json)', 'g')
const str = `blablabla
theObject = {
key1 = value1,
key2 = "test } test",
key3 = {
key4 = value4,
key5 = value5
}
}
blablabla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}