import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\+\\s*\\n(\\s*)";
final String string = " public void plugins_group_id_not_textual() throws IOException {\n"
+ " pluginsFailure(\"{\" +\n"
+ " \" \\\"plugins\\\": {\" + \"hola\" + \n"
+ " \" \\\"onePlugin\\\": {\" +\n"
+ " \" \\\"groupId\\\": 2\" +\n"
+ " \" }\" +\n"
+ " \" }\" +\n"
+ " \"}\");";
final String subst = "\\n\\1+ ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}