$re = '`\s*\+\s*\n(\s*)`';
$str = '    public void plugins_group_id_not_textual() throws IOException {
        pluginsFailure("{" +
                "   \\"plugins\\": {" + "hola" + 
                "       \\"onePlugin\\": {" +
                "           \\"groupId\\": 2" +
                "       }" +
                "   }" +
                "}");';
$subst = "\n\1+ ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;