import Foundation
let pattern = #"\s*\+\s*\n(\s*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public void plugins_group_id_not_textual() throws IOException {
pluginsFailure("{" +
" \"plugins\": {" + "hola" +
" \"onePlugin\": {" +
" \"groupId\": 2" +
" }" +
" }" +
"}");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n\1+ "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)