#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\h+constraint\h+[^,]*)(,?)"
Local $sString = "This is with something extra constraint xhiho," & @CRLF & _
"" & @CRLF & _
"This is without something extra constraint hfdlh"
Local $sSubst = "$2 --$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)