// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\h+constraint\h+[^,]*)(,?)").unwrap();
let string = "This is with something extra constraint xhiho,
This is without something extra constraint hfdlh";
let substitution = "$2 --$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}