package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\h+constraint\h+[^,]*)(,?)`)
var str = `This is with something extra constraint xhiho,
This is without something extra constraint hfdlh`
var substitution = "$2 --$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}