use strict;
my $str = 'This is with something extra constraint xhiho,
This is without something extra constraint hfdlh';
my $regex = qr/(\h+constraint\h+[^,]*)(,?)/mp;
my $subst = '$2 --$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";