$re = '/(\h+constraint\h+[^,]*)(,?)/m';
$str = 'This is with something extra constraint xhiho,
This is without something extra constraint hfdlh';
$subst = "$2 --$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;