const regex = /(\h+constraint\h+[^,]*)(,?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\h+constraint\\h+[^,]*)(,?)', 'gm')
const str = `This is with something extra constraint xhiho,
This is without something extra constraint hfdlh`;
const subst = `$2 --$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);