using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\h+constraint\h+[^,]*)(,?)";
string substitution = @"$2 --$1";
string input = @"This is with something extra constraint xhiho,
This is without something extra constraint hfdlh";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}