# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>//gmi;t' <<< "In other words <img src = \"http://example.com/images/someimage.jpg\"> needs to stay. But, <img src = \"cid:ii_id8bx9qh0_14f205b0a5e7738a\"> needs to go. "