import re
regex = re.compile(r"<img\b[^>]*src\s*=\s*\"cid[^\"]*\"[^>]*>", flags=re.MULTILINE | re.IGNORECASE)
test_str = "In other words <img src = \"http://example.com/images/someimage.jpg\"> needs to stay. But, <img src = \"cid:ii_id8bx9qh0_14f205b0a5e7738a\"> needs to go. "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)