const regex = /<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\b[^>]*src\\s*=\\s*"cid[^"]*"[^>]*>', 'gmi')
const str = `In other words <img src = "http://example.com/images/someimage.jpg"> needs to stay. But, <img src = "cid:ii_id8bx9qh0_14f205b0a5e7738a"> needs to go. `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);