import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\b[^>]*src\\s*=\\s*\"cid[^\"]*\"[^>]*>";
final String string = "In other words <img src = \"http://example.com/images/someimage.jpg\"> needs to stay. But, <img src = \"cid:ii_id8bx9qh0_14f205b0a5e7738a\"> needs to go. ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}