// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>"#).unwrap();
let string = "In other words <img src = \"http://example.com/images/someimage.jpg\"> needs to stay. But, <img src = \"cid:ii_id8bx9qh0_14f205b0a5e7738a\"> needs to go. ";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}