package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>`)
var str = `In other words <img src = "http://example.com/images/someimage.jpg"> needs to stay. But, <img src = "cid:ii_id8bx9qh0_14f205b0a5e7738a"> needs to go. `
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}