#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)<img\b[^>]*src\s*=\s*"cid[^"]*"[^>]*>"
Local $sString = "In other words <img src = "http://example.com/images/someimage.jpg"> needs to stay. But, <img src = "cid:ii_id8bx9qh0_14f205b0a5e7738a"> needs to go. "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)