#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
" so.addVariable("playlist", "http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml");" & @CRLF & _
" so.addVariable("autoplay", "false");" & @CRLF & _
"" & @CRLF & _
" // ]]>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")