use strict;
my $str = '
so.addVariable("playlist", "http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml");
so.addVariable("autoplay", "false");
// ]]>
';
my $regex = qr/(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}