$re = '/(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml/';
$str = '
so.addVariable("playlist", "http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml");
so.addVariable("autoplay", "false");
// ]]>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);