package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml`)
var str = `
so.addVariable("playlist", "http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml");
so.addVariable("autoplay", "false");
// ]]>
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}