// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml").unwrap();
let string = "
so.addVariable(\"playlist\", \"http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml\");
so.addVariable(\"autoplay\", \"false\");
// ]]>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}