re = /(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml/
str = '
so.addVariable("playlist", "http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml");
so.addVariable("autoplay", "false");
// ]]>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end