import re
regex = re.compile(r"(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml")
test_str = ("\n\n"
" so.addVariable(\"playlist\", \"http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml\");\n"
" so.addVariable(\"autoplay\", \"false\");\n\n"
" // ]]>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")