import Foundation
let pattern = #"(http:\/\/)?(www\.)?salvavinilos\.org\/.*\/playlist\.xml"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
so.addVariable("playlist", "http://www.salvavinilos.org/audio/O/orquesta sinfonica orfeon lamas/maestro vicente emilio sojo/playlist.xml");
so.addVariable("autoplay", "false");
// ]]>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}