# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<script([^>]*)?>.*?<\\/script>//g;t' <<< "1<script type='text/javascript'>2</script>3<script type='text/javascript'>3</script>5<script>..</script>"