re = /<script([^>]*)?>.*?<\/script>/
str = '1<script type=\'text/javascript\'>2</script>3<script type=\'text/javascript\'>3</script>5<script>..</script>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result