using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<script([^>]*)?>.*?<\/script>";
string substitution = @"";
string input = @"1<script type='text/javascript'>2</script>3<script type='text/javascript'>3</script>5<script>..</script>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}