import Foundation
let pattern = #"<script([^>]*)?>.*?<\/script>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1<script type='text/javascript'>2</script>3<script type='text/javascript'>3</script>5<script>..</script>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)