// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<script([^>]*)?>.*?<\/script>").unwrap();
let string = "1<script type='text/javascript'>2</script>3<script type='text/javascript'>3</script>5<script>..</script>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}