use strict;
my $str = '1<script type=\'text/javascript\'>2</script>3<script type=\'text/javascript\'>3</script>5<script>..</script>';
my $regex = qr/<script([^>]*)?>.*?<\/script>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";