const regex = /<script([^>]*)?>.*?<\/script>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<script([^>]*)?>.*?<\\\/script>', 'g')
const str = `1<script type='text/javascript'>2</script>3<script type='text/javascript'>3</script>5<script>..</script>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);