# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b/${abrev}${roman}\L${prep}\E\U${first}\L${rest}/gmxu;t' <<< "alto dO cruzeiro
joão paulo II
N.S. aparecida
N.S. DAS GRAÇAS"