import re
regex = re.compile(r"""
\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b
""", flags=re.MULTILINE | re.VERBOSE | re.UNICODE)
test_str = ("alto dO cruzeiro\n"
"joão paulo II\n"
"N.S. aparecida\n"
"N.S. DAS GRAÇAS")
subst = "${abrev}${roman}\\L${prep}\\E\\U${first}\\L${rest}"
result = regex.sub(subst, test_str)
if result:
print(result)