import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\n"
+ "(\n"
+ " (?<abrev>(?:[A-Z]\\.)+)\n"
+ " |(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))\n"
+ " |(?<prep>(?i)d?[aoe]s?(?-i))\n"
+ " |(?<first>\\w)(?<rest>\\w+)\n"
+ ")\n"
+ "\\b";
final String string = "alto dO cruzeiro\n"
+ "joão paulo II\n"
+ "N.S. aparecida\n"
+ "N.S. DAS GRAÇAS";
final String subst = "${abrev}${roman}\\L${prep}\\E\\U${first}\\L${rest}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}